网易微博换皮肤功能可以写入css

编号1101
Urlhttp://www.wooyun.org/bug.php?action=view&id=1101
漏洞状态厂商已经确认
漏洞标题网易微博换皮肤功能可以写入css
漏洞类型XSS跨站脚本攻击
厂商网易
白帽子呆子不开口
提交日期2011-01-10 01:15:00
公开日期2011-02-13 15:00:00
修复时间(not set)
确认时间2011-01-10 00:00:00
Confirm Spend0
漏洞标签css css内容xss
关注数0
收藏数0
白帽评级
白帽自评rank5
厂商评级
厂商评rank18
漏洞简介
网易微博换皮肤功能可以写入css
漏洞细节

就是那些颜色值,背景图等,只转义了尖括号标签,但其他的如双引号,大括号等都没过滤,这样用户可以写入恶意的代码,执行css语法

POC

修复方案

状态信息 2011-01-10: 细节已通知厂商并且等待厂商处理中
2011-01-10: 厂商已经确认,细节仅向厂商公开
2011-01-20: 细节向核心白帽子及相关领域专家公开
2011-01-30: 细节向普通白帽子公开
2011-02-09: 细节向实习白帽子公开
2011-02-13: 细节向公众公开
厂商回复非常感谢支持,呆子的观察力很细致....
回应信息危害等级:高漏洞Rank:18 确认时间:2011-01-10 10:05
Showing 1-5 of 5 items.
评论内容评论人点赞数评论时间

简洁但精辟

剑影02015-08-17 21:25:00

我想知道 这个漏洞为什么没有细节

刘海哥02015-07-27 09:37:00

我想知道 这个漏洞为什么没有细节

M4sk02015-07-14 01:19:00

我想知道 这个漏洞为什么没有细节

scanf02015-03-20 17:10:00

每个都是这么简洁

possible02013-04-01 09:21:00